in this senario ,i will provide three cases
case 1
one of cisco router interfaces will be DHCP client
case 2
cisco router will act as DHCP server provide ip address,subnetmask , default gateway,dns address and tftp address
case 3
cisco router will act as DHCP rely agent btween DHCP client and DHCP server on different network address
Router(config-if)#exit
Router(config)#interface Ethernet1/0
Router(config-if)#ip add dhcp
Router(config-if)#no sh
case 2 commands :
Router(config)#interface Ethernet1/1
Router(config-if)#ip address 13.0.0.1 255.0.0.0
Router(config)#ip dhcp pool net4
Router(dhcp-config)#network 13.0.0.0 255.0.0.0
Router(dhcp-config)#default-router 13.0.0.1
Router(dhcp-config)#dns-server 10.0.0.2
Router(dhcp-config)#option 150 ip 10.0.0.2
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 13.0.0.1 13.0.0.10
Router(config)#ip domain-name 10.0.0.2
case 3 commands:
Router(config)#interface FastEthernet0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#ip helper-address 10.0.0.2
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface FastEthernet0/1
Router(config-if)#ip address 11.0.0.1 255.0.0.0
Router(config-if)#ip helper-address 10.0.0.2
Router(config-if)#no shutdown
i made all these cases on one Packet tracer lab , i attached the pkt file with this document.
toplogy used
No comments:
Post a Comment